451 smart fortwo

smart Car

I just had my car wash with a jet washer. And now the abs light came on and the tracion light also came on.The wheels felt that the brakes were on and there was a burning smell. I left it for an hour and drove a few miles and it seams ok but do I need to be worry

Views: 248

Reply to This

Replies to This Discussion

hi, did you ever get a reply for this, I had the same problem and still do...dont know what to do

Sounds like water in a connector (or connectors) somewhere.  This can cause all sorts of issues.  Without knowing which connectors are the cause it's hard to attack the problem but people have had success using dielectric grease to waterproof any exposed electrical connectors.  Check this SCoA post: http://www.smartcarofamerica.com/forums/f4/afraid-rain-38828/index2...

Reply to Discussion

RSS

MADNESS GoPedal

Members

Latest Activity on 451s

Randy Sandberg commented on George Oller's photo
Thumbnail

245

"Now, that's the way to pack a garage!!! :-)"
Dec 10
Randy Sandberg commented on smartvot's photo
Thumbnail

SMARTVOT from GREECE

"AMAZING photo of an amazing car. Talk about wallpaper worthy. Seriously beautiful!!! :-)"
Dec 10
Randy Sandberg commented on Shane's photo
Thumbnail

Anxiously awaiting the Shipping Truck

"AWESOME color combination! :-)"
Dec 10
argiros commented on argiros's photo
Thumbnail

smart 450 body kit

"there is only one wide body kit for smart 451 .and we have it since 2008! handmade and…"
Dec 7

smartCar on Facebook/Twitter

© 2014    

Badges  |  Bug Report  |  Terms of Service

Disclaimer: This is a user generated "Web 2.0" community, smart GmbH, smart USA and smart Canada are not responsible for the maintenance or creation of this page.
All brand names and/or trademarks used are for reference only and are the property of their respective holders.